CentOS7将Python2.7.5 升级到Python3.5.2

第1步:更新gcc,gcc版本太老会导致新版本python包编译不成功

复制代码代码如下:
yum -y install gcc
系统会自动下载并安装或更新,等它自己结束

第2步:下载Python3.5.2软件包

复制代码代码如下:
wget https://www.python.org/ftp/python/3.5.2/Python-3.5.2.tgz

说明:命令中的数字就是版本号,你也可以把3.5.2换成你需要的版本。

第3步:解压已下载的二进制包并编译安装

复制代码代码如下:
  1. 解压:tar -zxvf Python-3.5.2.tgz
  2. 进入解压目录: cd Python-3.5.2
  3. 创建安装目录: mkdir /usr/local/python3.5.2
  4. 编译: ./configure -prefix=/usr/local/python3.5.2
  5. 安装: make && make install
  6. 备份原有python:mv /usr/bin/python /usr/bin/python2.7.5

第4步:建立软连接指向到当前系统默认python命令的bin目录,让系统使用新版本python

  mv /usr/bin/python /usr/bin/python2.7.5 //当前python的版本为2.7.5
  ln -s /usr/local/python3.5.2/bin/python3.5  /usr/bin/python 
输入:
    python -V

即可查看当前默认python版本
默认的python成功指向3.5.2以后,yum不能正常使用,需要修改yum的配置文件

第5步:修改yum配置文件

 vi /usr/bin/yum 
把文件头部的
      !/usr/bin/python
改成
      !/usr/bin/python2.7.5 //改为之前的老版本号 
保存退出,yum即可正常使用。如若有其他命令、软件不能正常使用,仿照yum配置文件的修改方法,修改其配置文件即可。至此,更新完毕。

第6步:修改另外一个相关的配置文件

 vi  /usr/libexec/urlgrabber-ext-down
该配置文件与yum install 命令有关,如果不修改该文件会报错
 File "/usr/libexec/urlgrabber-ext-down", line 28    except OSError, e:

这是因为python版本不匹配:
把文件头部的
      !/usr/bin/python
改成
      !/usr/bin/python2.7.5 //改为之前的老版本号 
0